Back to overview
Downtime

AWS outage on US-east-1 affecting our services

Oct 20 at 03:11am EDT
Affected services
Operations Center
Team Manager
Team Manager API (v3)
Team Manager API (v2)
User Accounts

Resolved
Oct 20 at 06:03am EDT

Most AWS services on us-east-1 have recovered and our services are now operational again.

Created
Oct 20 at 03:11am EDT

A major AWS outage in the us-east-1 region is impacting the services in the US. Sign-ins and other core functionalities may be unavailable. The situation is being monitored closely.

AWS status updates are available at: https://health.aws.amazon.com/health/status