Back
Degraded

Some users are experiencing issues with Team Manager mobile apps

Started 24 Mar at 12:51pm EDT, resolved 25 Mar at 10:56am EDT.

Team Manager
Resolved

The issue affecting the D4H Personnel & Training and Equipment mobile apps has now been resolved. Please update your mobile app to version 2025.3.3.

If you continue to experience difficulties after updating, try clearing the cache in the D4H app(s). If problems โ€‹still persist, please email us at help@d4h.com, and we will โ€‹cโ€‹onnect with you to troubleshoot.

Posted 25 Mar at 10:56am EDT.
Created

Personnel & Training - Some users are reporting some screens appear blank on the mobile app on selected phone models. We recommend uninstalling an re-installing the application if this affects you. We are working on a new release which should resolve this. Please contact help@d4h.com of this has impacted you.

Equipment Management - It is currently not possible to create a new activity when logging equipment usage through the mobile app. This issue has been resolved and is awaiting distribution approval on the app stores. A workaround is to create the activity on the browser then select it on mobile.

We expect a release to be approved for distribution within less than 24 hours. These issues are due to our migration to a new higher performance Team Manager API which provides our new platform for granular permissions, performance, and significant future advancements.

Posted 24 Mar at 12:51pm EDT.