Back
Degraded

Some Team Manager users are unable to access their dashboard.

Started 24 Apr at 09:54am EDT, resolved 24 Apr at 12:40pm EDT.

Team Manager
Resolved

Users are now able to go back into their Team Dashboard when clicked into the team name. Please note that we continue to monitor it.

Posted 24 Apr at 12:40pm EDT.
Created

A small number of users have reported difficulty accessing their Team Manager dashboards. We have already attempted a number of fixes which has resolved the issue for most people who have reported it, and we continue to work on a resolution for everyone.

Posted 24 Apr at 09:54am EDT.