Back
Resolved

Issue with SMS delivery for Multi-Factor Authentication
Started 31 Jan at 08:00am EST.
User Accounts
Created
We're currently experiencing issues with our SMS delivery service for multi-factor authentication (MFA). This may impact users trying to receive SMS codes for account access. Our team is working towards a resolution. We apologize for any inconvenience and appreciate your patience.
Posted 31 Jan at 08:00am EST.