Back
Degraded

Some administrators are unable to invite new users.

Started 16 Oct at 05:27pm EDT, resolved 17 Oct at 05:13am EDT.

Operations Center
Resolved

We have identified the root cause of this issue and applied a fix. All administrators should now be able to continue to invite new users.

Posted 17 Oct at 05:13am EDT.
Created

We're aware of an issue resulting in some administrators being unable to invite new users.

Our teams are working on a fix for this issue at present and and expect it to be resolved by approximately 5am Eastern Time Zone.

Thank you for your patience.

Posted 16 Oct at 05:27pm EDT.